FFKA-Firmware mit Gluon-2016.2

Hallo zusammen,

Gluon 2016.2 wurde gestern Veröffentlicht. Also habe ich mich noch gestern Abend hingesetzt und unsere Konfiguration an die aktuelle Gluon Version angepasst. Der große Firmware Rundumschlag steht also bevor.

Aber erst einmal ein paar Neuerungen die es dank Gluon 2016.2 gibt.
Es gibt viele neue Hardware die nun unterstützt wird.
Nennenswert sind hier vor allem:

  • Die Archer Serie von TP-Link
  • Die Unifi AC Serie von Ubnt
  • Direkte Images für den Raspberry Pi

Auf Seite der Bugfixes ist aus meiner Sicht vor allem der DNS Bug bei Statischer IP-Adresse zu nennen.

Alle weiteren Änderungen findet ihr wie immer auf der Seite vom Gluon:
http://gluon.readthedocs.io/en/v2016.2/releases/v2016.2.html

Unsere Firmware wird es noch heute Abend zwei Updates geben:

  1. eine neue Beta Version die weiterhin beide Meshing-Verfahren aktiviert hat.
  2. eine neue Experimental Version die nur noch 11s aktiviert hat und damit die Images für unter anderem die Archer Serie.

Wenn dir beiden Versionen ausreichend getestet sind, können wir die neue Stabile Version ausrollen, bei der wie geplant zuerst das 11s Mesh Netz umbenannt wird und und wir dann in einem zweiten Schritt nur noch 11s benutzt.

Außerdem möchte ich @jnsp dafür danken das er unserer Firmware Seite eine Generalüberholung verpasst hat.

Grüße,
Simon (herrbett)

2 „Gefällt mir“

PoE Pass-Trough kann nun auch an den CPEs aktiviert werden und besonders schön ist auch noch:

batman-adv: mesh_no_rebroadcast is now enabled for Mesh-on-WAN/LAN

@herrbett melde dich nochmal, sobald die Firmwares “online” sind, würde dann meine nodes von beta auf experimental umstellen, habe ja auf der WBS210 eh schon 2016.2 laufen…

Außerdem können wir nun 802.11b abschalten :slight_smile:

Gleich weg damit… :wink:

In den nächsten 30 Minuten sollte die Beta bereits online gehen.

Die Experimental braucht noch etwas länger, da der Server auf dem ich sie baue nur 2 und nicht 4 Kerne hat.

Ist ja wie mit meinem Laptop :smile:

So, alle neuen Versionen sind jetzt veröffentlicht.

Viel Spaß.

1 „Gefällt mir“

Experimental geht nicht über den autoupdater?!

root@ffka-schuetzen8a_hof:~# autoupdater -b experimental
Connecting to 0.updates.services.ffka.net ([2a03:2260:a::7]:80)
-                    100% |*******************************| 34731   0:00:00 ETA
There seems to have gone something wrong downloading the manifest from http://0.updates.services.ffka.net/firmware/experimental/sysupgrade
No usable mirror found.

Kannst du es bitte noch mal versuchen. Bis eben war das Manifest nicht signiert, dank eines Typos in einem meiner Scripte.

1 „Gefällt mir“

Läuft! :wink: Vielen Dank nochmal!

EDIT: CPE210 ist wohl nun tot :confused: nach dem Update kann ich sie nicht mehr erreichen…

CPE ist wohl nur noch via mesh erreichbar und nicht mehr über das LAN…

Sind hier womöglich die LAN und WAN Ports vertauscht?! Die CPE210 mit experimental mesht auch nicht mit meiner WBS210, nur noch mit dem schuetzen8a_str (der die nicht aktuelle beta hat)

EDITEDIT: beim WR1043nd v2 das selbe Problem… Auch vom LAN aus nicht mehr erreichbar…

Okay, Entwarnung: die Geräte haben sich (obwohl eigentlich fest vergeben) neue IP-Adressen abgeholt bei meiner Fritzbox - warum? Ist die letzten Updates jedenfalls nicht passiert…

Na, ich bin falsch… Trotzdem strange, dass die Geräte nicht mehr mit meiner WBS210 meshen wollen… :frowning:
Muss ich mir später mal im Detail anschauen…

Mesh läuft, hab das gluon für die WBS210 nochmal mit dem entsprechenden gluon2016.2 branch der site ffka gebaut.
Wenn ich jedoch auf nextnode.ffka gehe, “springen” die Nodes immer wieder auf inaktiv… Das lief vorher irgendwie bedeutend besser durch…

Gerade getestet, KexAlgorithms curve25519-sha256@libssh.org funktioniert mit der latest beta, juhu. :smile: So wurde meine ssh config wieder ein bisschen kürzer. :wink:

1 „Gefällt mir“

Für den Fall dass es jemand noch nicht gemerkt hat: Die Firmware wurde als stable ausgerollt.

Mac auf wan hat sich geändert, eventuell muss da der eine oder andere bei sich nachregeln.

Gluon 2016.2 hat einen Bug, bei dem das WLAN bei manchen ath9k Chipsätzen nach einiger Zeit ausfällt. Ein Fix gibt es in Gluon 2016.2.1 (noch nicht veröffentlicht). Ein reboot löst das Problem temporär.

Dann sieht es wohl so aus als würden wir bei Veröffentlichung ein Update Nachschieben müssen.

Ein Neustart der Netzwerkinterfaces per wifi sollte es auch tun und geht deutlich schneller. Iirc macht der Bugfix auch nichts anderes.

Ich kann das Problem nicht nachvollziehen. Es soll wohl meshende Nodes mit wenig RAM treffen… Habe an der WBS210 und CPE210 aber wohl genug RAM. Erst gestern / heute hat mal jemand kurz 80 GB über meine WBS210 gesaugt, am Stück… :wink:
EDIT: Bin eh raus, ibss0 habe ich in der experimental eh nicht mehr.
@herrbett wo gibt es hierfür eigentlich die Siteconf? Hatte die letzte aus git gezogen, aber bei dem selbst gebauten Image für die WBS210 ist ibss0 noch da…

Das Problem gibt es schon länger in verschiedenen Varianten. Soweit ich das überblicke ist es in der aktuellen Version lediglich noch bei ibss drin.

Da wir bereits das neue mesh parallel laufen haben, kann man eigentlich ibss0 manuell deaktivieren.

Ich hatte mir bisher mit https://github.com/eulenfunk/packages/tree/master/gluon-linkcheck beholfen - das macht genau das passende und hat mir den einen oder anderen Ausfall verhindert.