Firmware 0.6.2 - beta --> stable


#1

Hallo,

ich setze aktuell TP-Link 1043N V5 ein (ffgi-704f57455ea8). Zum Testen bin ich im Dezember von “stable 0.5.3” auf den “beta 0.6.2” Zweig gewechselt. Die Firmware funktioniert auch prima. Mesh-VPN und WLAN-Mesh laufen stabil. Jetzt habe ich gesehen, dass inzwischen auch im “stable”-Zweig die 0.6.2 angeboten wird und wollte entsprechend auf diesen wieder wechseln. Allerdings wird das Firmware-Update mit der Warnung “fehlende Signaturen” abgebrochen. Bisher hatte ich mit Wechseln zwischen “beta” und “stable”-Zweig nie Probleme.

Ich hatte mit

uci set autoupdater.settings.branch=stable && uci commit autoupdater
autoupdater -f

den Zweig gewechselt und erhalte dann die Fehlermeldung

Retrieving manifest from http://1.updates.services.karlsruhe.freifunk.net/images/stable/sysupgrade/stable.manifest
autoupdater: warning: manifest http://1.updates.services.karlsruhe.freifunk.net/images/stable/sysupgrade/stable.manifest only carried 1 valid signatures, 2 are required
Retrieving manifest from http://0.updates.services.karlsruhe.freifunk.net/images/stable/sysupgrade/stable.manifest
autoupdater: warning: manifest http://0.updates.services.karlsruhe.freifunk.net/images/stable/sysupgrade/stable.manifest only carried 1 valid signatures, 2 are required
autoupdater: error: no usable mirror found

Fehlt mit eine Unterschrift in der pupkey-Liste? Aktuell habe ich hier folgende Einträge:

autoupdater.stable=branch
autoupdater.stable.mirror=‘http://0.updates.services.karlsruhe.freifunk.net/images/stable/sysupgrade’ ‘http://1.updates.services.karlsruhe.freifunk.net/images/stable/sysupgrade
autoupdater.stable.good_signatures=‘2’
autoupdater.stable.name=‘stable’
autoupdater.stable.pubkey=‘18d66390413ffafd6210a8c87a4a67abbd613a1636eb017e887849cbf235232b’ ‘33a18ad9585fbd1a89e3eee235e9ff12bd8317332579a940736b8042764dc327’ ‘b18909758248ab642fce296734fb2243961f596ef48ad94bddde05b88a9fc9dd’ ‘021e46de58fa6b89b9f3715a85ad16cb27846085c889477328b46a629312a235’ ‘ddd06a809d9b882ea967c875871b25ed06b4e85c6dd8ce046a671d5e17812adc’ ‘2a5fca07bd12e5c05daf53022701caa7e5891faff24fdbdcca3614d2b0c8b0c3’

VG Kai


#2

Hallo Kai,

das Signaturen Fehlen ist richtig so. Wir rollen die Firmware schrittweise aus, weil wir versuchen alle Communites die unser Backbone nutzen wieder auf einen Stand zu bringen. Bis jetzt ist die Firmware nur für die Ortenauer Knoten signiert.

Wenn du die Firmware trotzdem updaten möchtest dann kannst du mit

uci set autoupdater.stable.good_signatures='1'
autoupdater -f

Ein Update mit nur 1 Gültigen Signatur erzwingen, nach dem Update sind aber wieder 2 Signaturen für die die darauf folgende Stable erforderlich.

Grüße,
Simon


#3

Hallo Simon,

ich probiere es aus und gebe eine Rückmeldung.

Danke für die schnelle Hilfe!

VG Kai

EDIT: Der Router ist nach dem Update auf “stable” wieder sauber hochgekommen und mesht brav mit einem aus dem “beta”-Zweig. - Danke nochmal :slight_smile: